BENDIX/KING

Mobile Communications Division

BK REF 006-01284-0000

P/N 0301-2045-300 11-94



o
—.v"’(ﬁ

INTRODUCTION

This preliminary manual prowdes instructions for using UCOM
software to program Tone Decode and Inversion Scrambling in Bendix/
King radios equipped with the Universal Communications Options
Module (UCOM). Tone Decode is a standard feature of UCOM.
Inversion Scrambling is an option that can be enabled only at the
factory (LAA 572).

To use this software, you will need:

ArR4BM or compatible computer with a floppy disk dnve an RS-
232 sarial port, and MS-DOS 3.3 or later

An RS-232 Interface Cable, available from Bendix/King
A mouse pointing device (optional)
The UCOM software diskette (LAA 760)

START THE PROGRAM _

1. Connect the interface cable to the radio and the computer’s
serial port. Note whether the serial port is COM 1 or COM 2.

Tum the computer and the radio on.

Place the UCOM software diskette in the computer's disk
drive. If desired, copy the program to a directory in a hard disk
drive.

4. Atthe DOS prompt, type UCOM and press Enter.
The default serial port is COM 1.
Start the program by typing UCOM 2 if using COM 2.

The UCOM Editor program displays information in three screen
formats:

Channel Edit Screen Alt-H
Scramble Frequencies Screen Alt-S
Codeset Edit Screen Al-C

~ UCOM EDITOR h Page 1



CHANNEL EDIT SCREEN

—Ucom Editor

File Edit Radio

Help

Ch
Ch
Ch
Ch
Ch
Ch
~Ch
Ch
Ch
Ch 10
Ch 11
Ch 12
Ch 13
Ch 14

WU WR

Group 1

*Codeset*

*Mod
NONE
NONE
NONE
NONE
NONE
NONE
NONE
NONE
NONE
NONE
NONE
NONE
NONE
NONE

e*

o
I ad

The opening screen in the UCOM program is the Channel Edit Screen.
This screen allows tone signalling codesets or scramble frequencies to
be selected for individual channels.

If tone signalling codesets or scramble frequencies have not yet been

created, open the Codeset Edit screen to create them.

To open the Codeset Edit Screen press Alt-C or select Codeset edit

from the Edit Menu.

To return to the Channel Edit Screen press Alt-H or select Channel

edit from the Edit Menu.

Function keys for the Channel Edit Screen include:

Page Up

Page Down

Tab or right arrow
Shift-Tab or left arrow
up arrow

down arrow

Next Group
Previous Group
Move right one field
Move left one field
Move up one field
Move down one field
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Alt-F -~ Open File menu

ARl-E . Open Edit menu
Alt-R Open Radio menu
F1 Open Help screen
Esc Cancel an operation

Spacebar or Double-click Open menu for current field

CODESET

Press the spacebar or double-click the mouse to display a list of four
available Scramble frequencies or Decode codesets.

Freqs - Select from the list by clicking the mouse or pressing the
arrow keys, then the Enter key. If scrambling is installed in this
radio, enter or change scramble frequencies on the Scramble
Frequencies Screen or the Codeset Edit screen, both under the
Edit Menu at the top of the screen.

Codeset - Select from the list by clicking the mouse or pressing
the arrow keys, then the Enter key. Create or modify a codeset
on the Codeset Edit Screen, under the Edit Menu at the top of the

screen.
MODE
Press the spacebar or double-click the mouse to select:
NONE No UCOM functions enabled for the
current channel.
SCRAMBLE _ If installed, enables scrambling on the
current channel. .
DECODE Allows tone decoding on the current
channel.

NOTE: You must select a MODE for the channel before selecting
a CODESET.

NOTE: If you are using a mouse, select a field or open a menu by
clicking on it. Double-click to open a menu of options for

that field.
NOTE: Inversion Scrambling is an option that can be enabled only
at the factory.
UCOM EDITOR Page 3



MENU BAR

The menu bar at the top of the screen contains File, Edit, and Radio
menus plus Help. Open a menu by pressing Ait-F for File, Ait-E for
Edit, or Alt-R for Radio. If you are using a mouse, open a menu by
clicking on it. Select a menu option by pressing the arrow keys (and

Enter), clicking with the mouse, or pressing the highlighted letter in the

first word.

. FILE MENU  Alt-F
Open data file
Save data file
Exit

EDITMENU AR-E
Codeset edit Alt-C
Channel edit Alt-H
Scramble edit  Alt-S
Clear scramble channels

Clear decode channels

RADIO MENU AIt-R
Upload data from radio
Download data to radio

HELP F1

.

- Read data from a file into editor

Save current editor data to a file
Exit program

Edit tone signalling codeset %

Edit channel programming data
Edit scramble frequencies

Clears scramble operation on any
channels for which it is programmed

Clears decode operation on any
channels for which it is programmed

Transfer radio from radio to éditor.

Transfers current editor data to radio.

Press F1 or click the mouse on the HELP option of the top menu to
display help relevant to the current operation. Repeat to display
increasingly more general help. Press any other key or click the
mouse anywhere else to exit HELP.

NOTE: The Help screen displays information about the current
field, menu, or screen. Press F1 several times to dusplay
different levels of help information. .
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SCRAMBLE FREQUENCIES SCREEN

Format: 1
r—Scramble Frequencies

Freq 1: 0000
Freq 2: 0000
Freq 3: 0000
Freq 4: 0000

To open the'Scramble Frequencies Screen press Alt-S or Séiect
Scramble edit from the Edit Menu.

Press the arrow keys or click the mouse to change fields,
then type in a frequency. -

Press Alt-space to exit and save changes.
Press ESC to exit and cancel changes.

NOTE: The numbered frequencies 1 through 4 are linked with the
codeset of the same number. The same value entered for
Freq 1 in the Scramble Frequencies Screen is also shown
with Codeset 1 in the Codeset Edit Screen.

NOTE: Inversion Scrambling is an option that can be enabled only
at the factory.
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CODESET EDIT SCREEN

File Edit Radio
Muting mode CLOSED/SQUELCH
Group tone mode Other
Reminder ENABLED
Tone set Custom
# tones 00
Tone 1 0000
Tone 2 0000
Tone 3 0000
Tone 4 0000
Tone 5 0000
Tone 6 0000

““Tone 7 0000
Tone 8 0000

Ucom Editor
Help
Codeset: 1
Codeset name CODESET1
Traffic Monitor DISABLED
Decode always DISABLED
Scramble always DISABLED
Group Tone 0000 )
Repeat Tone 0000 ™
Scramble Fregq 0000
Tone Spacing(ms) 0000
Tone duration(ms) 0000
Group tone duration(ms) 0000
Message time(Sec/8) 00

To open the Codeset Edit Screen press Alt-C or select Codeset edit
from the Edit Menu . This screen allows a tone signalling codeset to

be created or modified. *:\,
Function keys for the Codeset Edit Screen include: ’
Page Up Next codeset '
Page Down Previous codeset
Tab or right arrow Move right one field

Shift-Tab or left arrow

up arrow

down arrow

Alt-F

AI-E

Alt-R

F1

Esc

Spacebar or Double-click

NOTE: The scramble frequencies for all four codesets are displayed in

Move left one field
Move up one field
Move down one field
Open File menu
Open Edit menu
Open Radio menu
Open Help screen
Cancel an operation

Toggle field setting or
Open menu for current field

the Scramble Frequencies Screen.

NOTE: Inversion Scrambling is an optlon that can be enabled only at

the factory
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CODESET NAME

Enter a name that describes the current codeset. This name will be
appear in a menu when you are selecting a Codeset in the Channel
Edit Screen.

MUTING MODE

CLOSED/SQUELCH— Ali traffic is ignored until the radio is called.
The radio then switches to carrier/codeguard squelch for the period
of time specified in the Message Time field.

SQUELCH/OPEN—The radiooperatesincarrier/codeguard squelch
mode until the radio is called. It then unmutes for the penod of time
specified in the Message Time field.

CLOSED/OPEN— Al traffic is ignored until the radio is called. The
radio then unmutes for the period of time specified in the Message
Time field.

SQUELCH/BEEP— Radjo operates in normal carrietr/codeguard
squelch and beeps when the radio is called. if REMINDER inhibit is
not set, the radio continues to beep until a knob or switch is changed,
indicating that a message was received.

GROUP TONE MODE

TWO TONE— Select this for a two tone system with a long group
tone. The GROUP TONE DURATION controls the length of this tone
if the option is selected.

Other— Select this for all other systems.

REMINDER

If enabled, the radio will beep at regular intervals if the radio is called
and the Muting Mode is SQUELCH/BEEP.

TONE SET

Press the spacebar or double-click to display a list of predefined
tonesets. Use the mouse or arrow keys to move the cursor and select
atoneset. Selecting a toneset will set configuration parameters for
the specified signalling system and make available a list of valid tones
when editing a tone field.

The CUSTOM setting allows tone frequencies and parameters to be
entered ditectly. All tone set frequencies are rounded to the nearest
Hertz. Only with the CUSTOM setting will you be able to modify
GROUP TONE, REPEAT TONE, TONE SPACING, TONE
DURATION, or GROUP TONE DURATION settings.

UCOM EDITOR Page 7



# TONES

If TONE SET is CUSTOM, enter the number of tones in the ID tone
sequence (e.g. 2 foratwotone systemor 5fora 5/6 tone system). The
maximum is 8 tones. The number of tones is preset if TONE SET is
not CUSTOM.

TONE 1
TONE 2...

Enter a tone frequency (Hz) for each tone in the ID tone sequence. If
TONE SET is not CUSTOM, press the spacebar or double-click the
-mouse to display and select valid tones for the Tone Set.

TRAFFIC MONITOR

If enabled, any traffic on the current channel will be monitored after the
radio is called. The radio will retum to normal operation whgn any
knob or switch is changed.

-),
3

DECODE ALWAYS

If enabled, the action of the Muting toggle switch will be ignored and
- theradio willalways be intone decode mode for all channels for which
this current codeset is programmed.

If disabled, muting is turned on and off using the left toggle switch,
marked HI/LO or TA.

SCRAMBLE ALWAYS

If enabled, the action of the Scrambler toggle switch will be ignored
and the radio will always be in scramble mode for all channels for
which the current scramble frequency is programmed.

If disabled, the scrambler is turned on and off using the left toggle
switch, marked HI/LO or TA.
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GROUP TONE

Enter the frequency (Hz) of the Group tone for the desired signalling
system. It is only used if the GROUP TONE MODE is OTHER. If
TONE SET is not CUSTOM, this field cannot be modified.

REPEAT TONE

Enter the frequency (Hz) of the repeat tone for the desired signalling
system. If TONE SET is not CUSTOM, this field cannot be modified.

SCRAMBLE FREQ

Enterascramblerinversion frequency (Hz). If achannel programmed
with this codeset has SCRAMBLE mode selected in the Channel Edit
Screen, this frequency will be used as the scrambler inversion
frequency. Note that this frequency can also be edited in the
Scramble Frequencies Screen.

TONE SPACING(mS)

Enter the gap (milliseconds) between tones in the ID tone sequence.
If TONE SET is not CUSTOM, this field cannot be modified.

TONE DURATION

Enter the length of the ID tone (milliseconds). If TONE SET is not
CUSTOM, this field cannot be modified.

GROUP TONE DURATION

Enter the length of the GROUP TONE (in milliseconds). This
parameter is ignored unless the GROUP TONE MODE is OTHER. If
TONE SET is not CUSTOM, this field cannot be modified.

MESSAGE TIME

Enter the length of time (1/8ths of a second) the radio will remain
unmuted after being called.
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INTRODUCTION

The Universal Communications Options Module (UCOM) is an
options board that can be installed in BK Radio E Series portable
radios. UCOM has built-in Tone Decode capability and can be
purchased with optional Inversion Scrambling.

UCOM comes from the factory ready to be programmed with the
Tone Decode and/or Inversion Scrambling options to suit the user's
needs. Dealers can program UCOM options by computer using
UCOM Editor software (LAA 0760) and an RS-232 serial cable
(LAA 0725), both of which are available from BK Radio, Inc.

Yz

This supplement to the Owner's Manual describes special
operating procedures for radios equipped with UCOM. It is written
for the radio end user. Standard operating procedures for radios
with or without UCOM are described in the Owner's Manual.

Each section of this supplement describes a typical UCOM
configuration. Because of the many possible configurations, consult
your dealer or communications manager to determine the actual
operation procedures for your radio. A check box is placed beside
each section for the dealer to indicate which procedures apply.

Check for Instaliled UCOM

You can tell whether a UCOM board is installed by turning the radio
on. The radio gives a power up beep and UCOM gives another
beep. If the radio does not give two beeps when turned on, it is not
equipped with a UCOM board. However, this test does not indicate
whether or not UCOM has been programmed.

TONE DECODING

The UCOM module can be programmed to decode various tone
signalling systems such as 5/6 tone (CCIR, ZVEI, EEA, etc.) and 2
tone sequential (Quik Call Il, Reach, etc.). Up to 4 codesets can be
controlled using the Channel Select knob. Muting can be turned
On and Off automatically by using the Channel Select knob or
manually by using a toggle switch. Muting can be combined with
Codé Guard operation. Channels can also be programmed for
clear operation only (no tone decode).
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D Muting—Channel Knob

[ ] No Muting—Alert tones only

Turn the Channel Select knob to the channel with the proper
codeset. The UCOM module beeps when it receives the correct
tone sequence. After 20 seconds* the radio beeps again,
indicating the end of the timeout period.

The UCOM module beeps every 20 seconds* to alert you that you
have been called. To reset UCOM after the message, turn the
Squelch knob clockwise off the detent and then back on. A beep
indicates that UCOM has reset.

Before transmitting on a Code Guard channel, monitor the channel
by turning the Squelch knob clockwise off the detent position. If the
channel is clear, press the PTT switch and talk, releasing the PTT

switch to listen.

Turn the Channel Select knob
to the channel with the proper
codeset. With the Squelch
knob in the detent position
(full counterclockwise), no
traffic will be heard until the
correct tone sequence is
received. The UCOM module beeps when it receives the correct
tone sequence, and the radio unmutes for 20 seconds*. After 20
seconds* the radio beeps again, indicating the end of the timeout
period, and resumes the original muting condition.

The UCOM module beeps every 20 seconds* to alert you that you
have been called. To reset UCOM after the message, turn the
Squeilch knob off the detent and then back on. A beep indicates
that UCOM has reset.

Before transmitting, monitor the channel by turning the Squelch
knob clockwise off the detent position. If the channel is clear, press
the PTT switch and talk, releasing the PTT switch to listen.

*The 20-second delay can be programmed to a different duration.

[ ] Muting—Toggle Switch
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Turn the Channel Select knob
to the channel with the proper
codeset and turn on the -
Muting toggle switch (the left
toggle switch marked HI/LO
or TA). With the Squelch
knob in the detent position Muting Toggle Switch

(and the toggle switch on), no (LO or TA ="on")

traffic will be heard until the correct tone sequence is received.
The UGOM module beeps when it receives the correct tone
sequence, and the radio unmutes for 20 seconds*. After 20-
seconds* the radio beeps again, indicating the end of the timeout
period, and resumes the original muting condition.

OFF- VOL

The UCOM module beeps every 20 seconds* to alert you that you
have been called. To reset UCOM after the message, turn the
Squelch knob off the detent and then back on, or turn the toggle
switch off and then back on. A beep indicates that UCOM has
reset.

Before transmitting, rﬁonitor the channel by turning the Squelch
knob clockwise off the detent position. If the channel is clear, press
the PTT switch and talk, releasing the PTT switch to listen.

SCRAMBLING OPERATION

If optional Inversion Scrambling is installed, UCOM can be
programmed to scramble transmit audio, making it unintelligible to
the casual listener. The receiving UCOM radio unscrambles the
audio using the proper code. Up to 4 codes can be controlled using
the Channel Select knob. Scrambling can be turned On and Off
automatically with the Channel Select knob or manually with a
toggle switch (the left toggle switch marked HI/LO or TA).
Scrambling can be combined with Code Guard operation.
Channels can also be programmed for clear operation only (no
scrambling).
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[ ] Scrambling—Channel Knob

To receive a scrambled
message, turn the Channel
Select knob to the channel
with the proper code. Signals
with the same code will be
unscrambled and heard. All
other signals (including clear)
will be unintelligible or distorted. To receive these other sngnals
turn the Channel Select knob to the proper position.

To transmit a scrambled méssage, turn the Channel Select knob to
the channel with the proper code. Before transmitting on a Code
Guard channel, monitor the channel by turning the Squelch knob
clockwise off the detent. Regardless of the signal distortion, wait
until the channel is unoccupied before transmitting.

[ ] scrambling—Toggle Switch

To receive a scrambled
message, turn the Channel
Select knob to the channel
with the proper code. Turn on
the Scrambler toggle switch
(the left toggle switch marked
HI/LO or TA). Signals with the Scrambler Toggle Switch
correct code will be (LO or TA ="on")
unscrambled and heard. All

other signals (including clear) will be unintelligible or distorted.

' orr? VOL

To receive a signal that has not been scrambled, turn off the
Scrambler toggle switch. To receive other coded traffic, turn the
Channel Select knob to the channel with the proper code and turn
on the Scrambler toggle switch.

To transmit a scrambled message, turn the Channel Select knob to
the channel with the proper code, and turn on the Scrambler toggle
switch. Before transmitting on a Code Guard channel, monitor the
channel by turning the Squelch knob clockwise off the detent.
Regardless of the signal distortion, wait until the channel is
unoccupied before transmitting.
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